Knowledgebase: HFM
Error: "Registered app is not active at the moment, please consult your system administrator" in SSL-enabled environment
Posted by Priya Doyle on 08 December 2010 05:24 PM

Error: "Registered app is not active at the moment, please consult your system administrator" in SSL-enabled environment [ID 597451.1]

 Modified 19-OCT-2010  

Applies to:

Hyperion Financial Management - Version: 4.1.1.0.00 to 9.3.1.4.00 - Release: 4.1 to 9.3
Microsoft Windows (32-bit)

Symptoms

In a SSL-enabled environment (where the HFM web interface is accessed with "https://..."), when clicking on an application name in HSS, the user receives an error: "Registered app is not active at the moment. Please consult your system administrator."

Changes

This issue might be triggered by enabling SSL in an environment which was previously configured and working.

Cause

HSS contacts HFM by using a web service, talking over HTTP or HTTPS depending on the Security Management URL specified when the application is created or registered.

If this background conversation is broken at the HTTP/HTTPS level, you will see errors like these in the SharedServices_Admin.log:

2007-05-11 14:28:48,484 [Thread-16] ERROR com.hyperion.cas.server.task.CASActiveContextPingerTask.run(CASActiveContextPingerTask.java:52) - IOException occured while pinging app with registered context path: https://hfmwebserver.companyname.com:443/HFM/security/: Refer log in debug mode for details

See the last paragraph of Note 737405.1 for how to turn on debug mode.

In an SSL-enabled environment, this might mean that the SharedServices process is trying to make an HTTPS request without the required SSL certificate being registered in a Java keystore. If that is the case, you should see a clear error once debug mode is on.

Solution

Find the cacerts file, which is certificate keystore responsible for the web-application process, and import the SSL certificate used by HFM webserver to this file, using the standard keytool command:

keytool -import -alias <hostname> -keystore cacerts -trustcacerts -file <certificate file name>

The location of cacerts varies depending on your configuration and on the web application server HSS was deployed with (WebLogic, WebSphere etc). Consult the documentation for your Vendor.

For auto-deployed Tomcat instances shipped with HSS from 4.1.1 to 9.3.1, the right file is one of these:
  • <HYPERION_HOME>\common\JDK\Sun\1.4.2\jre\javaws\cacerts
  • <HYPERION_HOME>\common\JDK\Sun\1.4.2\jre\lib\security\cacerts
  • <HYPERION_HOME>\common\JRE\Sun\1.4.2\javaws\cacerts
  • <HYPERION_HOME>\common\JRE\Sun\1.4.2\lib\security\cacerts
Once the certificate has been safely imported into the correct keystore, restart HSS, reproduce the issue and check that the SharedServices_Admin.log doesn't report the above error anymore.

References

NOTE:737405.1 - Error "Registered app is not active at the moment. Please consult your system administrator." when clicking on application name in Shared Services


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