Knowledgebase: FDM
Data Access Error" Importing an XML File in a New Financial Data Quality Management (FDQM) Application via the Workbench
Posted by Priya Doyle on 25 January 2011 10:50 AM
"- 2147217833 - Data Access Error" Importing an XML File in a New Financial Data Quality Management (FDQM) Application via the Workbench [ID 1053441.1]

 Modified 27-JAN-2010 

Importing and XML file in a new FDQM application via the Workbench client, errors with: 

"- 2147217833 - Data Access Error"; when "Import Maps with Locations" is selected in the "Options" tab. 

If the Maps are not selected, the import loads successfully.

The *.err log file gives the following errors:

ERROR:
Code............................................. -2147217833
Description...................................... ORA-01401: inserted value too large for column
Procedure........................................
clsDataManipulation.fProcessRecord
Component........................................ upsWDataWindowDM
Version.......................................... 1111
Thread........................................... 2220

and 

ERROR:
Code............................................. -2147217833
Description...................................... Data access error.
Procedure........................................ clsImport.ImportLogicGroups
Component........................................ upsWMetaMgrDM
Version.......................................... 1111
Thread........................................... 2220

IDENTIFICATION:
User............................................. admin
Computer Name.................................... XXXX
App Name......................................... FDM_TEST
Client App....................................... WorkBench

Cause


This issue has been logged as Unpublished Bug 9147450.

The column size of the target table is likely to be the cause of the problem.




Solution


The issue has been resolved with FDM version 11.1.1.3.0  Upgrading to FDM version 11.1.1.3.0 will resolve the issue.  If an upgrade is not an option the following is an available workaround:

A. Import the XML without the Maps in the new FDQM application.
B. Then, export the Maps to Excel in the original FDQM application and import the resulting *.XLS files in the new FDQM application.

Procedure:
  1. Launch the FDQM Web Server Component, and log in the original FDQM Application.
  2. Go to Activities->Maps, select a "Dimension" and a "Type" and click on "Export to Excel".  
  3. Save the exported *.xls file in a location of your choice (i.e. Inbox). 
  4. Log in to the new FDQM application and go to Tools->Import XLS
  5. In the "Upload File" tab, click on "Browse", select the exported *.XLS file and "Open"
  6. Click on the "Import" button.
The above procedure will need to be done for all the Dimensions and Types and all the Locations in the FDM Application.


(0 vote(s))
Helpful
Not helpful

Comments (0)
Post a new comment
 
 
Full Name:
Email:
Comments: