Knowledgebase: Enterprise
Hyperion Enterprise Web Logon Fails with "Error: Module not Found in He.hecontainer'
Posted by Priya Doyle on 15 February 2011 04:49 PM

Hyperion Enterprise Web Logon Fails with "Error: Module not Found in He.hecontainer"

 Modified 19-JAN-2010     Type PROBLEM  

Applies to:

Hyperion Enterprise - Version: 6.4.1.0.00 - Release: 6.4
Information in this document applies to any platform.

Symptoms


When logging on Hyperion Enterprise Web the following error occurs:  "Hyperion Enterprise Error: Module not Found He.hecontainer".


Cause

This is a coding issue and started to occur after the 1st  of January 2010.

This is unpublished BUG 9259234.

Solution

1. Shutdown Hyperion Enterprise Web and reset IIS.

2. Locate locFuncs.asp at the following locations:

where % denotes your installation drive.

 a. %Hyperion Solutions%\Hyperion Enterprise\HEWeb 
 b. %Hyperion Solutions%\Hyperion Enterprise\HEWeb\modules\com\hyperion\bpm\web\desktop 
 c. %Hyperion Solutions%\Hyperion Enterprise\HEWeb\modules\com\hyperion\he\web\hecontainer 
 d. %Hyperion Solutions%\Hyperion Enterprise\HEWeb\modules\com\hyperion\he\web\hedesktop 
 e. %Hyperion Solutions%\Hyperion Enterprise\HEWeb\modules\com\hyperion\he\web\helogoff 
 f. %Hyperion Solutions%\Hyperion  Enterprise\HEWeb\modules\com\hyperion\he\web\helogon 
 g. %Hyperion Solutions%\Hyperion @ Enterprise\HEWeb\modules\com\hyperion\he\web\hestartup 

3. Take a backup of the original locFuncs.asp.

4. Locate the line: 

Response.Cookies("DisplayLanguage").Expires = #January 01, 2010# 

5.  Replace 2010 with 2030 for the year field: 

i.e., Response.Cookies("DisplayLanguage").Expires = #January 01, 2030# 

6. Perform this change inside locFuncs.asp, located in the folders mentioned in step 2. 

7. Re-boot the server.

8. Retry logging onto Hyperion Enterprise Web to confirm it works as expected. 


(0 vote(s))
Helpful
Not helpful

Comments (0)
Post a new comment
 
 
Full Name:
Email:
Comments: