Knowledgebase: Enterprise
Unable to Post Journal Even Though User Has Modify Rights to Post Journal Security Class
Posted by Priya Doyle on 16 February 2011 12:01 PM

Unable to Post Journal Even Though User Has Modify Rights to Post Journal Security Class

 Modified 17-SEP-2010     Type PROBLEM     Status PUBLISHED 

Applies to:

Hyperion Enterprise

Symptoms

Unable to post journal.
User created a journal but cannot post that same journal even though user has Modify rights to post journal security class.

Cause

User has only VIEW access to a security class attached to one or more application elements (accounts and entities) in the journal entry.

Solution

To create a journal entry, the user needs MODIFY access to the journal module but needs only VIEW access to all application elements selected in the entry.


However, to post that same journal the user needs MODIFY access to the Post Journal task as well as MODIFY access to all application elements selected in the journal entry. 

For example, User1 created the following journal entry:


Entity1, Account1, 1000
Entity2, Account1, -1000
Entity3, Account2, 1000
Entity4, Account2, -1000


All journal tasks have the MAXIMUM class attached. 
All entities have the MAXIMUM class attached excepting Entity4 which has the CHANGE class attached. 
All accounts have the MAXIMUM class attached excepting Account1 which has the OPTION class attached. 
If User1 has MODIFY access to all three of these classes, he can create and post this journal entry. 
However, if User1 has MODIFY to MAXIMUM and CHANGE but only VIEW to OPTION, he can create this entry but will not be able to post it. 
Also, if User1 has MODIFY to MAXIMUM and OPTION but only VIEW to CHANGE, he can create but cannot post. 
Finally, if User1 has less than MODIFY to MAXIMUM, he will not be able to create nor post a journal.


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