Knowledgebase: HFM
Error: "Invalid Parameter" when Smartview Query contains Japanese, Turkish or Double Byte Characters
Posted by Priya Doyle, Last modified by Priya Doyle on 11 November 2010 10:52 AM
 Modified 14-SEP-2010 

Applies to:

Hyperion Financial Management - Version: 11.1.1.1.00 to 11.1.1.3.00 - Release: 11.1 to 11.1
Information in this document applies to any platform.

Symptoms


"Invalid Parameter" can error when the following operations are being performed in Hyperion Smartview

- refresh/refresh all/submit data Query Designer
- refresh/refresh all/submit data Web Form
- refresh/refresh all/submit data Excel sheet HsGetText(), HsSetText() function are used

The error occurs when one of the following is true, 

1) If the Web Data Entry Form name or Folder Name in HFM application contains double byte characters, the error can occur when opening the form.

2) When the Cell Text of any included cell contains double byte characters, the error can occur when the data is submitted to HFM.

3) When the metadata description of any displayed member includes double byte characters, the error can occur when the data is submitted to HFM.

Cause

This has been identified as a code issue on the provider (server) side of the HFM Smartview provider in all 11.1.1.x versions of HFM (before 11.1.2).

Specifically there is a problem with tracking the size of a stream which contains double byte characters.The problem is only reproducible when compression is enabled on the provider.

Solution

Workaround:

1. On the Financial Management web server locate the following registry key in the Windows Registry
HKEY_LOCAL_MACHINE\SOFTWARE\Hyperion Solutions\Hyperion Financial Management\HFMWebServiceManager\OfficeProviderEnableHTTPCompression

2. If the parameter is currently set to value 1, change the parameter to value 0.

3.  Save the change, close the Windows Registry and in Windows Services, restart the service called "Hyperion Financial Management - Web Service manager"

4.  Connect once again from Smartview client to the HFM provider and test the issue again.



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